Degraded Performance

Incident Report for Supercast

Update

We are continuing to monitor for any further issues.
Posted Dec 05, 2025 - 19:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 21:47 UTC

Monitoring

We are experiencing degraded performance across the app. We anticipate this resolving in the next 30 minutes.
Posted Dec 04, 2025 - 21:47 UTC
This incident affects: Supercast Application.