Episode Publishing Issues

Incident Report for Supercast

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 15:29 UTC

Investigating

We've heard some reports of published episodes being excessively delayed in being sent to podcast players. We are investigating now.
Posted Jan 07, 2026 - 19:38 UTC
This incident affects: Private Feeds and Episodes.