Application slow down

Incident Report for Supercast

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 18:57 UTC

Monitoring

We are monitoring the performance, we should recover shortly.
Posted Nov 11, 2025 - 18:02 UTC
This incident affected: Supercast Application.