Issues playing audio episodes in subscriber area

Incident Report for Supercast

Resolved

This issue is resolved
Posted Jun 01, 2026 - 15:48 UTC

Identified

There's currently an issue playing audio episodes in the subscriber area. We're working on resolving this and it should be fixed within the next 10 minutes.
Posted Jun 01, 2026 - 15:33 UTC
This incident affected: Supercast Application.