App Outage

Incident Report for Supercast

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 20:31 UTC

Investigating

Investigating slowdowns
Posted Oct 28, 2025 - 18:51 UTC

Monitoring

Servers are back online, monitoring closely as we catch up from the outage. Expect slower response times while we fully scale back up over the next hour.
Posted Oct 28, 2025 - 15:22 UTC

Update

We'll be bringing servers back online in ~10 minutes. We expect some degraded performance as things come fully online.
Posted Oct 28, 2025 - 14:46 UTC

Identified

We are in the process of making some updates that we feel should help with this.
Posted Oct 28, 2025 - 14:35 UTC

Update

The Supercast Application is currently down - we are working to resolve it and will update as soon as we have more information.
Posted Oct 28, 2025 - 14:18 UTC

Investigating

We are investigating decreased performance on the Supercast application.
Posted Oct 28, 2025 - 13:56 UTC
This incident affected: Supercast Application.